Service disruption on Searchie portal (app.membership.io)
Incident Report for Membership.io
Resolved
This incident has been resolved.
Posted Nov 18, 2024 - 05:50 EST
Investigating
We are currently experiencing a service disruption. Our team is working to identify the root cause and implement a solution.
Posted Nov 18, 2024 - 05:49 EST
This incident affected: Portal.