Payment Status and Account Access Reporting Error

Incident Report for Membership.io

Resolved

This incident has been resolved.
Posted Jul 31, 2025 - 09:50 EDT

Update

Fix Implemented Issues resolved we are monitoring the resolution for any other issues.
Posted Jul 30, 2025 - 18:12 EDT

Update

We have implemented a fix for the issue and are monitoring its progress. The resolution period is longer for those with larger audiences. We appreciate your patience.
Posted Jul 30, 2025 - 13:10 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2025 - 12:28 EDT

Identified

Please be advised some users may have seen a reporting error in cancelled member accounts reporting as being given "lifetime access"

We are working on a resolution and will have services and status reporting correctly as soon as possible.
Posted Jul 30, 2025 - 11:37 EDT