Service disruption on Searchie portal (app.searchie.io)
Incident Report for Membership.io
Resolved
This incident has been resolved.
Posted Sep 03, 2024 - 17:37 EDT
Investigating
We are currently experiencing a service disruption. Our team is working to identify the root cause and implement a solution.
Posted Sep 03, 2024 - 17:15 EDT
This incident affected: Portal.