Service disruption on Searchie Public Hubs
Incident Report for Membership.io
Resolved
This incident has been resolved.
Posted Apr 29, 2023 - 23:04 EDT
Investigating
We are currently experiencing a service disruption. Our team is working to identify the root cause and implement a solution.
Posted Apr 29, 2023 - 23:02 EDT
This incident affected: Public Hubs.